Help spread the word / share us on your favorite social media networks

Facebook Twitter StumbleUpon Reddit LinkedIn

Results 1 to 2 of 2

Thread: Old Super Tomahawk Chipper/Shredder w/Tecumseh 5hp engine (H50) stalls upon load

  1. #1
    Join Date
    Jan 2015
    Posts
    1

    Default Old Super Tomahawk Chipper/Shredder w/Tecumseh 5hp engine (H50) stalls upon load

    Chipper was inherited and had been out in the weather for at least two years. I just cleaned carb and replaced all gaskets except the crankcase gasket. Cleaned the top of the piston, sides of cylinder and inside of head. At first engine would only start with starter fluid. Now it will start on its own and run fine. Compressions tests slightly above 80psi. Chipper mechanism spins freely. However, as soon as I engage the clutch the engine stalls. Any ideas what's happening?

  2. #2
    Join Date
    Feb 2012
    Location
    Welland Ontario
    Posts
    405

    Default

    My guess would be you need more throttle or to adjust the carb hi speed under load.
    Operation Overlord.

Similar Threads

  1. Replacement part of Rheem Super Quiet 80 gas furnace pressure switch?
    By ilovebrownies in forum Heating & Air conditioning
    Replies: 1
    Last Post: 01-12-2017, 10:07 PM
  2. GE front load washer pump help
    By mnwill in forum Appliance Repair
    Replies: 5
    Last Post: 04-06-2015, 08:31 PM
  3. centennial load sensor or timer?
    By Boman in forum Appliance Repair
    Replies: 3
    Last Post: 12-29-2014, 09:50 PM
  4. Replies: 1
    Last Post: 11-01-2014, 09:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •