Results 1 to 2 of 2

Thread: Maytag smooth top element not working

  1. #1
    Join Date
    Mar 2019
    Posts
    607

    Default Maytag smooth top element not working

    Originally posted 5-02-2013 11:54 PM
    By: splatapus


    Hi everyone,

    One of the 6 inch element on my Maytag smooth top range ( model # PER5750QCW ) has just stopped working. I lifted up the ceramic top and saw that a very tiny piece on the strip of element metal was burned.

    I have found the replacement element, but my question is: is there a cheaper way to fix this? The burn on the strip of metal that makes up the element is very very small ( only 2 millimeters in length). Can't I just short it across the burned piece or something?

    Thank you in advance
    Last edited by jeff1; 05-15-2019 at 10:41 PM.

  2. #2
    Join Date
    Feb 2019
    Location
    Ontario Canada
    Posts
    422

    Default

    Originally posted 5-03-2013 7:45 AM

    New element time. Once the element is broken it is toast, element gets hot from the resistance of the coil, a plain piece of wire or such would just burn off.

    Click image for larger version. 

Name:	Radiant-Surface-Element-W10823711-05498729.jpg 
Views:	3 
Size:	7.4 KB 
ID:	714
    Surface element with limiter, 6 inch, 1200 watts

    jeff.
    Last edited by jeff1; 05-15-2019 at 10:43 PM.
    http://www.applianceaid.com/
    Appliance Repair Aid

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •