Results 1 to 2 of 2

Thread: Ultra SX 80 Blower motor

  1. #1
    Join Date
    Mar 2019

    Default Ultra SX 80 Blower motor

    Originally posted 3-05-2015 2:36 AM
    By: Christed

    I was trouble shooting my Ultra Sx 80 Furnace becuase it wouldn't light. I traced it back to the pressure switch and was able to get the lighter to glow by jumping the pressure switch. I took the pressure switch off and checked the switch and it worked, cleaned the hose and it didn't seemed plugged. Reinstalled the pressure switch and pressed reset button.

    But now my problem.... I can't get the blower motor to work for me now. It worked before I tested the pressure switch. I've turned power off and on, adjusted thermostat, and pressed a small reset button but all I get is a light huming sound from the board area and when I turn the furnace off I hear a switch activate in the board area. The fins turn easily. I don't have a code light on this model.

    Any help on trouble shooting the exhaust motor would be great....

  2. #2
    Join Date
    Mar 2019


    Originally posted 3-05-2015 7:51 PM

    by jumping the pressure switch.
    This is fine for troubleshooting, but do not leave it this way for any length of time. 3 kids were killed by carbon monoxide, with a 4th in the hospital near me last week. A malfunctioning furnace is being suspected. This is a critical safety switch. If it is not closing, then there is a reason. Not trying to scare you, I just REALLY hate seeing this stuff on the news..

    When you are saying blower motor are you talking about the actual blower that moves air throughout your house, or the inducer that creates a draft in your combustion chamber? I am assuming that you are referring to your inducer. If you are not, let us know.

    There are several safety switches/sensors (flame rollout(s), various temperature limit switches, etc) throughout the furnace. If any of these is open, then your furnace will not attempt to start a heating cycle. If you board is in a lockout state then it will not attempt either. Some boards can detect a bypassed or shorted pressure switch. Some boards have a reset procedure.. Typically powering off for at least 15 seconds will do it. A thermostat or wiring issue can also cause this. (if a relay clicks when your furnace receives a call for heat, then your thermostat circuit is probably ok)

    Buzzing is usually not a good thing from a board. Relays will not normally make nose other then a click. You could have a bad relay, or could have damaged something while bypassing things. Make sure everything is connected the way it was before, and make sure you did not knock anything loose.

    As for the original problem, you could have a blocked exhaust, failing inducer or bearings (motor can not spin at the correct speed), a leak in the vacuum line or the pressure switch, or a intake issue if your furnace has an air inlet. You likely will not be able to troubleshoot all of these without special equipment and knowledge. You may be better cutting your losses and calling someone out. Luckily spring isn't far off!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts