Help spread the word / share us on your favorite social media networks

Facebook Twitter StumbleUpon Reddit LinkedIn

Results 1 to 7 of 7

Thread: Furnace

  1. #1
    Join Date
    Dec 2014
    Posts
    4

    Default "Boom" when furnace ignites

    Armstrong Ultra sx 80. I replaced the flame sensor/pilot, cleaned the jets and tested the induction fan which is working properly and is not clogged. The only thing I can assume is that the valve is bad. Can anyone advise its getting cold in the house. Here is a video https://www.youtube.com/watch?v=bMuU...kuccdk7hY_HJUw
    Last edited by esodemann; 12-19-2014 at 01:38 PM. Reason: Moved to correct room by Mod

  2. #2
    Join Date
    Feb 2012
    Location
    Lala land, OH
    Posts
    235

    Default

    Can't view the video without signing in.

    What is the problem you are having? Be very specific or we wont be able to help you. Please describe exactly what is happening (if it's lighting and shutting down after____ happens, inducer spins up, igniter glows, etc... )

  3. #3
    Join Date
    Dec 2014
    Posts
    4

    Default

    Tries to light several times and each time flames shoot out towards the front before finally lighting.

  4. #4
    Join Date
    Feb 2012
    Location
    Lala land, OH
    Posts
    235

    Default

    This is called a rollout. They can be dangerous. This may be something you want to call a professional for.

    2 things can cause this...

    A lighting delay (think of turning the gas on to your stove/gas grill, then lighting the match... If you messed with the ignitor (sounds like you did) make sure you did not bend the bracket causing it to be further away from the burner. Make sure your burners are clean. If you have burners and not jets and the burner is plugged near the ignitor then it will delay ignition. If your burner is dirty then there IS a problem with your furnace that is causing it (have it professionally cleaned and checked over). Burners don't normally get dirty/plugged up.

    You have a combustion air problem. This can be *VERY* dangerous and create excess carbon monoxide that can leak into your house. Either the furnace is starved for combustion air or you could have a crack in your heat exchanger.

    If your ignitor bracket is not bent, I would suggest calling someone out to look at it.

  5. #5
    Join Date
    Dec 2014
    Posts
    4

    Default

    Fixed the video you should be able to watch it now

  6. #6
    Join Date
    Feb 2012
    Location
    Lala land, OH
    Posts
    235

    Default

    Did it do the same thing before you put these parts in?

    It sounds like the gas is on a second or so before the ignitor gets a good glow.

    Are you sure you have the correct ignitor? A wrong ignitor may not come up to temp as fast. Did it always have a hot surface ignitor? The videos I found all showed a spark ignition with a intermittent pilot. It's possible a previous homeowner may have modified it.

    When it ran correctly how did it light? Did the burners all light at the same time or did they light sequentually like they do now? Is the timing all the same? Does anythign happen quicker / slower?

    The rollout sensor is above and to the right of the rightmost burner. That is likely what is shutting the gas off when it attempts.
    Do not keep running it like this. Might be a good time to get someone in to look at it. You've done all you can do.

    Here's a similar furnace lighting correctly for comparison (dont need to watch past the first few seconds) Notice the smooth soft ignition.
    https://www.youtube.com/watch?v=mN5nj9lAbyA

  7. #7
    Join Date
    Dec 2014
    Posts
    4

    Default

    Fixed It.....It turned out to be the Smart Valve (not so smart) LOL. It was letting the gas out before the pilot lit. Got a new valve for $200 and now it works perfectly nice and quiet and smooth.

Similar Threads

  1. Armstrong Air Furnace - Failure to Ignite
    By ElectricPiper in forum Heating & Air conditioning
    Replies: 3
    Last Post: 10-03-2016, 04:27 PM
  2. Goodman furnace inducer fan cycles
    By admin in forum Heating & Air conditioning
    Replies: 1
    Last Post: 11-29-2015, 10:07 PM
  3. Furnace not working? READ HERE FIRST!!
    By Mr T in forum Heating & Air conditioning
    Replies: 4
    Last Post: 02-08-2015, 09:30 AM
  4. Heil NUGK 867 model furnace problem
    By lionround in forum Heating & Air conditioning
    Replies: 11
    Last Post: 11-25-2014, 09:40 PM
  5. furnace room door
    By roughrider in forum Building Construction
    Replies: 3
    Last Post: 07-21-2013, 07:16 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •