Appliance tip of the week...

Kenmore, Whirlpool, KithenAid dishwasher - upper rack not cleaning very well

So my top rack is consistently soiled and not clean - d/w is getting water to the top spray arm, but not spinning. I can tell by positioning the spray arm and mentally noting its position, starting the cycle and letting it run for a few...when I open it mid-cycle, the arm has not moved though I notice water is seeping out of the spray holes.

I have removed and cleaned the upper assembly and run water through each of the tubes in the complete system,I didn't find any blockage. The actual spray arm I took outside and ran the hose full through the inlet and had great flow/spray through all the holes. I reassembled and made sure everything was moving freely as it was previously with the same effect during the cycle - no spinning.

Watch this video first...

Video link is here

Check your chopper screen assembly to make sure its not clogged or broken also...

D/w upper rack not cleaning very well - Appliance tip of the week-food-chopper-assembly-w10083957-01072823-jpg Dishwasher drain food chopper assembly Manufacturer Number W10083957

D/w upper rack not cleaning very well - Appliance tip of the week-food-chopper-assembly-8268383-00610024-jpg Dishwasher drain food chopper assembly with screen Manufacturer Number 8268383

D/w upper rack not cleaning very well - Appliance tip of the week-check-valve-8268375-00621737-jpg Check valve, pump sump Manufacturer Number 8268375

jeff.