Help spread the word / share us on your favorite social media networks

Facebook Twitter StumbleUpon Reddit LinkedIn

GE Fridge/Freezer not getting cold

GE Fridge/Freezer not getting cold

Results 1 to 4 of 4

Thread: GE Fridge/Freezer not getting cold

  1. #1
    Join Date
    Jul 2013
    Posts
    2

    Default GE Fridge/Freezer not getting cold

    Morning all,

    Just trying to get a starting point as to what to look at for my fridge freezer. The thing has worked great for years, both fridge and upper freezer portion both. It is a GE model TBXSASGRWH. I just recently relocated to NC and took the fridge with me so I could keep drinks cold in the garage. It was unplugged for qabout a week and never was on its side or abused during shipping. When i plugged it in here at my new place it worked great again. But for a couple months I had no reason for it in the new garage yet so I just unplugged it instead of just running it for no reason. The other day we bought a half a beef and I wanted to put some meat in the freezer so I plugged it back up a day bfore the meat arrived. The light comes on. You can hear it is running but neither the freezer or the fridge get cold at all. You have to put the settings at the coldest for both the fridge and freezer to even remotely feel any coolness in both areas. What could have happened in the time it was unplugged? There are no leaks at all. We have had a crazy amount of rain here in NC for like a month straight and the garage is EXTREMELY humid and kinda funky smelling just due to the humidity and mildew smell in the garage. Think that could have messed with something? Any troubleshooting start points would be most welcome.

    Thanks

    Sid

  2. #2
    Join Date
    Feb 2012
    Location
    Canada
    Posts
    2,330

    Default

    Hi,

    TBXSASGRWH
    Normally some #'s after the TBX (18)(22).
    http://www.applianceaid.com/model-number.php

    The light comes on. You can hear it is running but neither the freezer or the fridge get cold at all.
    First is figure out what is or is not working.....evaporator fan motor in the freezer running, condensor fan motor ( beside the compressor ) running, compressor is running ( back bottom, usually behind a cardboard cover )?
    Has the condensor coils been cleaned recently? ( should be done once a year ).
    Some simple things to check...
    http://www.applianceaid.com/refriger...old-enough.php

    jeff.
    http://www.applianceaid.com/
    Appliance Repair Aid

  3. #3
    Join Date
    Jul 2013
    Posts
    2

    Default #'s for the GE model

    Quote Originally Posted by jeff1 View Post
    Hi,



    Normally some #'s after the TBX (18)(22). TBX18SASGRWH
    http://www.applianceaid.com/model-number.php

    Sorry Jeff. The numbers are a 18. Thank you for your help.

    Sid



    First is figure out what is or is not working.....evaporator fan motor in the freezer running, condensor fan motor ( beside the compressor ) running, compressor is running ( back bottom, usually behind a cardboard cover )?
    Has the condensor coils been cleaned recently? ( should be done once a year ).
    Some simple things to check...
    http://www.applianceaid.com/refriger...old-enough.php

    jeff.
    the numbers are 18.

  4. #4
    Join Date
    Feb 2012
    Location
    Canada
    Posts
    2,330

    Default

    TBX18SASGRWH
    A top freezer style.

    The light comes on. You can hear it is running but neither the freezer or the fridge get cold at all
    You have confirmed what is running?
    *If* the fans and compressor are running but no cooling we inspect the frost pattern on the evaporator/cooling coils in the freezer.
    That is behind the false back wall # 201...

    GE Fridge/Freezer not getting cold-e2138466-00003-png

    All evenly frosted, ball of ice, 1/2 frosted and 1/2 bare, etc.

    jeff.
    http://www.applianceaid.com/
    Appliance Repair Aid

Similar Threads

  1. Replies: 7
    Last Post: 01-10-2017, 09:56 PM
  2. kenmore 596.75232400 bottom freezer is not cold enough
    By chefj in forum Appliance Repair
    Replies: 5
    Last Post: 09-07-2015, 08:31 AM
  3. Freezer is Cold But fridge section is Warm...
    By jeff1 in forum Appliance Tip of the Week
    Replies: 0
    Last Post: 03-14-2015, 10:50 PM
  4. Summit FF-7B fridge not getting cold
    By bmwpower in forum Appliance Repair
    Replies: 2
    Last Post: 06-14-2014, 10:08 AM
  5. Fridge not cold
    By suemarkp in forum Appliance Repair
    Replies: 1
    Last Post: 03-06-2013, 07:45 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •