Help spread the word / share us on your favorite social media networks

Facebook Twitter StumbleUpon Reddit LinkedIn

GE front load washer pump help

GE front load washer pump help

Results 1 to 6 of 6

Thread: GE front load washer pump help

  1. #1
    Join Date
    Mar 2015
    Posts
    3

    Default GE front load washer pump help

    Hello,
    I'm looking for a bit of help with a GE front load washer with some pump issues, please!
    Model# GCVH6800J1WW

    Initially the washer wouldn't drain. I've cleaned the pump filter and checked the hoses....no problems there.
    I've removed the pump and run t05 and it worked fine while out of the machine. I did notice that the impeller and shaft would very easily slide in and out of the pump body...enough that when the motor and 'chamber' were assembled, the shaft would slide forward and rub on the opposite side if the chamber, and didn't seem to be running smoothly/consistently, and could easily be stopped. I'm guessing this indicates a new pump is required?

    When the pump should be running, there's 119V going to the contacts with no variance. When the pump should be at rest, my multimeter shows about 64V at the pump motor terminals. Is this normal or does it indicate an issue with the control board?

    Thank you for any advice!!

  2. #2
    Join Date
    Feb 2012
    Location
    Canada
    Posts
    2,381

    Default

    Hi,

    I'm guessing this indicates a new pump is required?
    Yes it would.

    When the pump should be at rest, my multimeter shows about 64V at the pump motor terminals. Is this normal or does it indicate an issue with the control board?
    I would rarely ever test for power at the pump when it shouldn't be running....but finding a reading there ( not full voltage ) would not be unheard of.

    GCVH6800J1WW
    Won't come up for me....Canadian model?....closest is GCVH6800J5WW

    GE front load washer pump help-drain-pump-wh23x10028-00720912-jpg Drain pump and motor assembly with sound isolation mounting washers

    jeff.
    http://www.applianceaid.com/
    Appliance Repair Aid

  3. #3
    Join Date
    Mar 2015
    Posts
    3

    Default

    Thank you for the help.
    It is a Canadian model.
    I'll pick up a pump locally (I've got a great parts shop nearby and the exchange is bad for me right now!) and update.

    Thank you

  4. #4
    Join Date
    Feb 2012
    Location
    Canada
    Posts
    2,381

    Default

    It is a Canadian model.
    Many Canadian models are not online.

    jeff.
    http://www.applianceaid.com/
    Appliance Repair Aid

  5. #5
    Join Date
    Mar 2015
    Posts
    3

    Default

    Pump is in, numerous loads done to catch up, working well and no leaks.

    Thank you for your help

  6. #6
    Join Date
    Feb 2012
    Location
    Canada
    Posts
    2,381

    Default

    Thankx for the update

    jeff.
    http://www.applianceaid.com/
    Appliance Repair Aid

Similar Threads

  1. LG front load washer making a scraping sound
    By Tymanthius in forum Appliance Repair
    Replies: 7
    Last Post: 05-16-2015, 08:41 PM
  2. kenmore front load washer leaking
    By ronenosity in forum Appliance Repair
    Replies: 1
    Last Post: 12-23-2014, 09:02 AM
  3. Frigidaire Front Load Washer Problem
    By John in forum Appliance Repair
    Replies: 1
    Last Post: 02-08-2014, 09:35 PM
  4. Front Load Washer / How it works - Appliance tip of the week...
    By jeff1 in forum Appliance Tip of the Week
    Replies: 0
    Last Post: 01-06-2013, 03:50 PM
  5. Kenmore front load washer
    By rcuevas in forum Appliance Repair
    Replies: 1
    Last Post: 03-06-2012, 09:23 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •