Help spread the word / share us on your favorite social media networks

Facebook Twitter StumbleUpon Reddit LinkedIn

Tappan Gas Oven Issues PLEASE HELP!

Tappan Gas Oven Issues PLEASE HELP!

Results 1 to 2 of 2

Thread: Tappan Gas Oven Issues PLEASE HELP!

  1. #1
    Join Date
    Aug 2014
    Posts
    1

    Default Tappan Gas Oven Issues PLEASE HELP!

    Hi My name is Corey and this is my first post here,

    Long story short, I bought a forclosure home and this oven was included and very clean so I would like to use it but I am having issues with the oven staying lit.

    From the START this is what the sypthoms have been and work thats been done:

    1.When "Preheating" oven Ignitor would glow, gas would light, and oven would start heating up. It would only stay lit for aprox 4-5 minutes then would go out with ignitor still glowing for a bit before it stopped glowing as well. The display would still read "Pre" as if is was still pre-heating. It seems to only heat up to 250 degrees F

    2. I replaced the Ignitor with a new unit-----No Change

    3. I replaced the Temp Probe with a new unit----No Change

    The top 5 burners have no issues with staying on and the only other issue is that the lower RH burner doesn't ignite on its own but once lit it will stay on.

    I am at a loss and need the oven to work. I do not have the funds for a whole new unit so if anyone has any ideas or suggestions I would be very greatful!

    Thank you for taking the time to read.

    Brand - Tappan
    Model # TGF657BFW5
    Age - 12yrs
    Last edited by CMANN1; 08-28-2014 at 02:34 PM. Reason: Typos

  2. #2
    Join Date
    Feb 2012
    Location
    Canada
    Posts
    2,348

    Default

    Hi,

    It would only stay lit for aprox 4-5 minutes then would go out with ignitor still glowing for a bit before it stopped glowing as well.
    That is unusual!

    2. I replaced the Ignitor with a new unit-----No Change
    3. I replaced the Temp Probe with a new unit----No Change
    New ignitor, new oven temp sensor....the gas valve should be ok or the ignitor and flame wouldn't have worked at the beginning....leaves the clock/control as the prime suspect.
    But the clock/control for your range is coming back as NLA.

    Tappan Gas Oven Issues PLEASE HELP!-oven-control-board-318010300-00592661-jpg Electronic clock

    I do not have the funds for a whole new unit so if anyone has any ideas or suggestions I would be very greatful!
    May need to send those parts back and start saving for a new range.....sorry!

    jeff.
    http://www.applianceaid.com/
    Appliance Repair Aid

Similar Threads

  1. Electrical issues at my home
    By zack in forum Electrical, Residential
    Replies: 7
    Last Post: 10-04-2017, 05:51 AM
  2. Oven Door Repair - Oven Light is Out - Appliance tip of the week
    By jeff1 in forum Appliance Tip of the Week
    Replies: 0
    Last Post: 12-19-2015, 12:35 PM
  3. Replies: 2
    Last Post: 06-21-2015, 12:24 AM
  4. Database Issues But Back up Now
    By dkerr in forum Site Server Issues / Problems
    Replies: 0
    Last Post: 09-11-2014, 07:01 PM
  5. tappan stove slow to come to temp
    By jiml in forum Appliance Repair
    Replies: 1
    Last Post: 08-23-2013, 09:29 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •