Help spread the word / share us on your favorite social media networks

Facebook Twitter StumbleUpon Reddit LinkedIn

GE Top Load Smart Clean washer problem

GE Top Load Smart Clean washer problem

Results 1 to 2 of 2

Thread: GE Top Load Smart Clean washer problem

  1. #1
    Join Date
    Jul 2014
    Posts
    1

    Default GE Top Load Smart Clean washer problem

    I have a GE top load washer, Model #WGA17502XPBO, not sure if they are supposed to be 0's or O's. I am having problems with the agitation.

    The washer fills fine, then when it goes to agitate, it begins to make a loud humming noise. The drum moves slowly, tries to agitate, but not effectively at all. And once the cycle starts I try changing the mode, and nothing happens. I can't get it to drain, and the only way to get it to stop is to unplug it.

    Any ideas?

    Thanks!

  2. #2
    Join Date
    Feb 2012
    Location
    Canada
    Posts
    2,330

    Default

    Hi,

    not sure if they are supposed to be 0's or O's.
    Normally zeros (0).

    WGA17502XPB0
    I got no where with this, please recheck.
    http://www.applianceaid.com/model-number.php

    jeff.
    http://www.applianceaid.com/
    Appliance Repair Aid

Similar Threads

  1. Samsung washer balance problem
    By Boman in forum Appliance Repair
    Replies: 15
    Last Post: 06-28-2015, 08:32 PM
  2. GE front load washer pump help
    By mnwill in forum Appliance Repair
    Replies: 5
    Last Post: 04-06-2015, 08:31 PM
  3. F02 washer problem -Appliance tip of the week
    By jeff1 in forum Appliance Tip of the Week
    Replies: 0
    Last Post: 10-03-2014, 10:32 PM
  4. Frigidaire Front Load Washer Problem
    By John in forum Appliance Repair
    Replies: 1
    Last Post: 02-08-2014, 09:35 PM
  5. Kenmore front load washer
    By rcuevas in forum Appliance Repair
    Replies: 1
    Last Post: 03-06-2012, 09:23 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •